Jump to content

Updates break Google Earth synchronisation features


Recommended Posts

Recent updates to Google Earth have changed things so that we can no longer manipulate the program from WAsP. This is apparently an irreversible change and they are not going to provide any alternatives.

We can restore some of the functionality by working in a different way, but other parts will be harder or impossible to fix.

Please, help us to decide what to do about this problem. Tell us whether and how you use the WAsP in conjunction with Google Earth.

Do you ever use the sync spatial view button to launch Google Earth?

If so, do you only want to view your data one time or do you care that the view and selection is synchronised between the programs?

Do you use the geo-referenced image capture feature?

Best wishes, Duncan.
Link to comment
  • 2 weeks later...
Hi Duncan,

I also noticed that, and suspected that the recent Google Earth update is to blame.

Personally I find the sync feature very useful, both for viewing objects and georeferencing backdrops. Viewing objects is very handy to verify that everything is in place. I use less frequently georeferencing of Google Earth backdrops for the purpose of digitization in the map editor, but still it is useful for e.g. doing small modifications of roughness lines.

Link to comment
Thanks very much for your contributions.

We have decided to try to restore at least part of the functionality. You will be able to launch the displayed information in Google Earth, but there will be no way we can automatically set the camera location and do other more advanced features.

I hope we can make an update in the next few weeks.

Link to comment
  • 2 months later...
Hello everyone. I'm sorry for the lack of news.

We have made good progress and now have some builds which we are testing internally.

It might be possible to release something soon. I'm thinking in then next week.

Meanwhile, anyone interested in testing or desperate for a fix is welcome to email me and we'll add you to the beta testing group.

Best wishes, Duncan.
Link to comment
  • 3 weeks later...
  • 3 weeks later...
  • 1 month later...
Hi. I've been using WAsP 10.2 and been trying to synchronize my layout to Google Earth. Unfortunately, the synchronization button in the spatial view is somewhat disabled/unclickable/not working. I have already set the projection of the virtual map but still no improvement. Can you help me please? thank you.
Link to comment
  • 3 weeks later...
  • 1 year later...
Dear all I am a user of WASP 11.6 and I continue with problems with GE

1) I have read that GE works with WSG84 datum but when I check where GE has placed the WTG I always find discrepancies ( I have checked with wind farms in operation)

2) Maybe it is an own problem (divX, drivers or whatever) but when I click the globe button and GE starts, it deploys the wind turbines but the icons don't appear

Thanks for your commentaries
Link to comment
Hi CA1,

Thank you for the feedback. While writing these I also saw your email to WAsP support and realized that you might have a problem with the WAsP installation. Still, I will keep this general advice, for other readers at this forum.

First it is important that turbine positions and the map inside WAsP apply the same projection and datum. If not, you must either transform the map or the turbine site list. This can be done outside WAsP using either the Map Editor (tools>transform>projection) for the map, or the WAsP Projection Transformer (File>transform XYZ file) for the turbine positions. When you input the aligned data, the turbine positions should display correctly inside WAsP.

WAsP needs to know the applied map projection and datum in order to make a translation before displaying the information correctly in Google Earth. You can right-click on the map and select ‘Set map projection’ if the projection or datum is unknown, but sometimes projection is included in the map information coming from the Map Editor. As far as I know WAsP will not try to translate the map relative to the turbine positions, i.e. you can use ‘Set map projection’ to provide missing information on projection and datum but not to fix a difference between map and turbine coordinates. This must be done before you load the data into WAsP as described above.

I must admit that I too have observed differences between the turbine positions displayed in Google Earth and turbines visible in the GE satellite images. I am not sure how big these should be before it is alarming, but I think you can expect precision around 10 m. If you choose the right projection but false datum, you may see differences on the order of 100m. If you have checked everything and still see significant offsets, then please send a sample project to WAsP support for inspection.

Turbine positions in GE are sometimes displayed by 3D models and sometimes by icons. This depends on the zoom factor.

Link to comment
  • 5 months later...
Hi there,

I have recently been given a new work computer and downloaded the latest version of GE. It is Version Google Earth Pro (32-bit). It is running on a computer using Windows 10 Enterprise Version 1703 Build 15063.608.

When I used to project a WAsP project results onto GE in the old computer running the old GE (non-pro) and Windows 7 all worked well. Now I try to project the same WAsP model that used to work, and it now does not. Has the recent GE Pro version now not allow me to use with WAsP?

Does the WAsP GE synchronisation still work or is it something i have updated? I get the synchronisation up onto GE but the hemispheres are now very wrong and my overlay from WAsP goes from an approx 41 deg south location to something up by the Alaskan coast? I am using UTM southern Hemisphere Zone 59 WSG84 in all my maps but I still end up in the wrong hemisphere.


Link to comment
Hello, which version of WAsP are you using?

There was a problem with a recent update which meant that some workspaces were not getting the projection correctly restored. I think in that case, if you set the map projection again for the vector map (by hand) then it should work.

This doesn't sound like a Google Earth related problem, more like something to do with our projection transformation work. Our code generates KML and then launches Google Earth to display that. If GE is responding at all, then GE is working. If the information rendered is wrong in some way (like the wrong hemisphere), then it's our code which is having problems.

Link to comment
Thanks Duncan,

It is WAsP Version 11.06.0012. Licenced user is me.

Map projection via the "Set Map Projection" dialog.

Projection: UTM Proj. S. Hemisph. | Southern Hemisphere
Zone: 59
Datum: WGS 1984




PS, following on from the theme above of how useful GE synchronisation is. I use it to explain the results of WAsP modelling to those who have trouble picturing the flat 2-D maps. With a GE overlay we can show where the wind is in a picture of the terrain they are familiar with. I tip the GE view to an oblique view that the viewer will recognise. It is a very useful feature for such visualisation and knowledge transfer.
Link to comment
Phil, I'm delighted to hear that you find the feature so useful.

Let's get it working for you again. There have been some problems with southern hemisphere information in a recent releases, and I thought that it was all sorted in the latest release. There is an updated wasp suite installer at http://www.wasp.dk/Download/WAsP12-Suite-Installer which includes a slightly newer build of WAsP 11. You could try that.

If no joy, then we'll need to have a look at your workspace. In that case, email me at duncan.heathfield@wasptechnical.dk and we'll set up a support casae.

Cheers, Duncan.
Link to comment
  • 4 months later...
Hi Duncan,

I seem to have the same problem as Phil, in that I can't get a site in the Southern Hemisphere to show up correctly in Google Earth (version That is, it's ends up in the Northern Hemisphere. However, I'm trying to do so from WEng3 (version 3.01.021). I'm also using Windows 10.

Could it be the same issue, as for WAsP11? If so, is there an easy fix? I also find the feature to be extremely useful.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...