#1 2020-09-01 11:09:30

Stefan
Member
Registered: 2014-12-11
Posts: 4

Execution of LIDAR correction script leads to an error

Dear WAsP team,

I've got the following error message executing the script "LiDAR_Error.wes3" in
WAsP Engineering 4.0.018:

Failed to execute the script LiDAR_Error.wes3 Modified 20.05.2016 12:47:04 because... the system reported that: 'Index außerhalb des gültigen Bereichs.'
(= index is out of the valid range)
Maybe the message has something to do with the script configuration regarding the Excel sheet generation or Excel evaluation but I am not really sure. I am using Excel (german version) of the MS Office Professional Plus 2016. Can you give me an advice how I get rid of the problem?

Many thanks in advance for your support and help!

Best regards

Stefan

Offline

#2 2020-09-01 11:22:26

Mark Kelly
WAsP team
From: Risø
Registered: 2010-07-13
Posts: 43

Re: Execution of LIDAR correction script leads to an error

Hi Stefan, it looks like perhaps the number of heights is having a mismatch, but we can't be sure without seeing the data.
Have you used the script successfully with other data (or previously with this same data)?
I'd recommend sending an email to WAsP-support, to also get the case in our system there.


Dr. Mark Kelly
WAsP Team,  Risø DTU

Offline

#3 2020-09-01 12:49:24

Morten
Administrator
From: DTU Wind Energy
Registered: 2009-11-02
Posts: 136
Website

Re: Execution of LIDAR correction script leads to an error

Hi Stefan,


I remember one detail which used to trouble me with this script: the Lidar and reference masts sites must be given the exact names ‘L’ and ‘M’, so maybe check this first. Apart from this, I have no idea of what might be wrong. As Mark suggest, you better submit a WEng project file illustrating the problem to WAsP support together with possible additional inputs (if required, I cannot remember) for the script.


Cheers,
Morten

Offline

#4 2020-09-01 15:39:55

Stefan
Member
Registered: 2014-12-11
Posts: 4

Re: Execution of LIDAR correction script leads to an error

Hi Morten and Mark,

thank your very much for your answers! I think it's not a problem with the names of the lidar/mast (L/M) or the number of heights - these data should be correct. I've send an additional email to the WAsP support including a screenshot of the error message and the settings. Maybe the problem can be solved...

Many thanks and best regards,

Stefan

Offline

#5 2020-09-01 17:41:01

Stefan
Member
Registered: 2014-12-11
Posts: 4

Re: Execution of LIDAR correction script leads to an error

Dear Mark and Morten,

I want to tell you that I currently could solve the problem by myself. As I had supposed, the error comes from the Excel sheet generation, which is called from the script. I found out, that if there are not enough sheets preseted under the excel options (in my case MS Office Prof Plus 2016 the standard setting = 1 sheet!) then the error occurres. If you set there a sufficient number of data sheets(say 4 or 5) - which actually should generated by the script - then everything works well! Maybe this hint or an appropriate adaption of the script could be useful for users with the same problem and Excel version...

Best Regards

Stefan

Offline

Board footer

Powered by FluxBB

[ Generated in 0.022 seconds, 12 queries executed - Memory usage: 528.21 KiB (Peak: 530.3 KiB) ]